Tutorial: Einbinden von Nuclos in IntelliJ IDEA

® Konfiguration
© Das Projekt neu bauen
® Mdgliche Probleme und Behebung

Lernziel

In diesem Tutorial lernen Sie, wie Sie ein Nuclos-Projekt in die Entwicklungsumgebung IntelliJ IDEA
einbinden.

Voraussetzungen

Funktionierende Installation des Nuclos-Projekts (im folgenden Projekt-Installation).
JetBrains Intellij IDEA Ultimate: https://www.jetbrains.com/idea/download/#section=windows
Maven

Git

Ajc Plugin fur Compiler Setting

Java

Unter Windows muss Git fur lange Dateinamen konfiguriert werden:

git config --system core.longpaths true

Sonstiges

® Das Projekt neu bauen
® Troubleshooting

Konfiguration

Bevor Sie mit der Konfiguration von IDEA beginnen, miissen Sie sowohl das git-Repository des Projekts (im folgenden Projekt-git), als auch das git-
Repository des Nuclos-Kerns (im folgenden Kern-git) klonen.

Wechseln Sie nun im git zu dem Tag des Kerns, welcher der Nuclos-Version der Projekt-Installation entspricht (git checkout).

Nun sind Sie bereit, die Konfiguration von IDEA anzugehen.


https://www.jetbrains.com/idea/download/#section=windows

Richten Sie maven ein: File ->
Settings -> Build, Execution,
Deployment -> Build Tools -> Maven

Stellen Sie sicher, dass unter File
Settings Build, Execution,
Deployment Compiler Java
Compiler der Ajc gesetzt ist (Dafir
notwendig ist das AspectJ Plugin
von IntellJ)
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Offnen Sie das Projekt (Projekt-git)
in IDEA: File -> Open...

Importieren Sie das Maven Projekt
(ein Popup sollte erscheinen).

Lassen Sie Maven die Quellen
generieren.

Stellen Sie die Profile-Settings ein
(je nach Projekt), mindestens aber
das quick-Profil
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Bauen Sie das Modul.

Nun kann der Kern-git eingebunden
werden. Offnen Sie zu diesem
Zweck die Modul-Einstellungen:
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Hier kann der Kern-git importiert
werden (Import Module):

Einige Sourcen werden in Nuclos
generiert und sind nicht im Git
eingecheckt.

Uber:

"nucl os-schema" > rechte
Maust aste > Maven >
Generate Sources and
Updat e Fol ders

werden die Sourcen generiert.

Projeck Structure
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= Batch Applications
@ Bean Validation
& CDL Contexts and Dependency Injection
& Concurrency Utils (JSR 236)
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Sobald das Modul geladen ist,
navigieren Sie ins Verzeichnis /[Pfad
zu Kern-git]/nuclos-war/src/main
/webapp/META-INF/.

Hier finden sie eine Datei context-
template.xml - Erstellen Sie eine
Kopie der Datei im selben
Verzeichnis und nennen Sie diese co
ntext.xml.

Passen Sie nun die vier value-
Parameter (von context.xml) an, so
dass diese auf die entsprechenden
Konfigurationsdateien zeigen, die
sich im Verzeichnis ihres
installierten Nuclos-Projekts (Projekt
-Installation) befinden.

Nun kénnen Sie auch fur den Kern
die Quellen mit Maven importieren
und das Modul bauen.

Anmerkung: Falls es im
Extension-Projekt eine
extension-war gibt, hat es
sich bewahrt, die context.
xml statt dessen dort zu
erstellen. also im
Verzeichnis /[Pfad zu Proj
ect-git]/<extension>-war
/src/main/webapp/META-
INF/. Das Verzeichnis /
[Pfad zu Kern-git]/nuclos-
war/src/main/webapp
IMETA-INF/ sollte dann
besser keine context.xml
enthalten.

Um den Server einzurichten, gehen
Sie auf Run -> Edit Configurations... :

J & context-template xml

ou s

<Environment

<Environment name="nuclos-conf-jdbc" type=
<Environment name="nuclos-conf-quartz" typ
<Environment

1 <7xmL version="1.0" encoding="UTF-8"7>
<l

Context-Template. Copy this file to "context.xml"

name="nuclos-conf-log4j" type="java.lang.String" value="

and adspt the following paths to your system.

>
<Context antiJARLocking="true" path="/nuclos-war" reloadable="false" sessionCookiePathUsesTrailingSlash="true">

"file: ///home/user/nuclos/nuclos-conf/conf/log4j2.xml"/>
ile: ///home/user/nuclos/nuclos-conf /conf/jdbc. properties”/>
: ///home/user/nuclos /nuclos-conf/conf/quartz. properties/>

a.lang.String” value=
ava. lang.String” valu

name="nuclos-conf-server” type="java.lang.String" value="file:///home/user/nuclos/nuclos-conf/conf/server.properties"/>

- [nuclos-war] - ~/git/nuclos-educcare-cor/nuclos-war/src/main/webapp/META-INF/context-temy
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Erstellen Sie einen neuen Tomeal-

Server: + %

Add New Configuration Press the+ button to create a new configura

¥ Gulp.js
-1 JAR Application
% JavaScript Debug
5 Jest
[@ JUnit
K Kotlin
K Kotlin (JavaScript)
K Kotlin script

Maven
O npm
@ NWjs
@ Protractor

React Native
(@ Remote
& Spy-js
& Spy-js For Node js
il TestNG
- Tomcat Server
8§ st

32 items more (irrelevant)...

Add New 'Tomcat Server' Configuration

= |ocal
& Remote
I




Konfigurieren Sie diesen:

A  Am besten’ Sie laden sich Application server: ‘Tomcat?ﬂﬂ n ‘ Configure ‘
p | den Tomcat-Server in der von e e
pl | Nuclos verwendeten Version D) afterlaunch | @ Default Bl | O wih Javascript debugger
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.
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r
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Unter Umstéanden missen noch die

© ) Run/Debug Configurations

+ -0 ¥
= Application
# Tomcat Server

Name: | Tomcat 7 |

O Share

SEWEF‘ Deployment | Logs | Code Coverage | Startup/Connection |

Ausfiihrungsrechte der Tomcat-Start-
Scripte gesetzt werden, z.B.:

chmod u+x apache-tomcat-..../*.sh



In manchen Fallen wird context.xml ece Project Structure
beim Deployment nicht in das target- * -

8 nuclos-war:war Name: nuclos-war:war exploded
® -war:

Verzeichnis tibernommen. Project Settings 8 nuclos-warwar exploded
Project Output directory: /nuclos/nuclos-war/target/nuclos-war
In diesem Fall hilft es die Datei L S Include in project build
Libraries
context.xml unter . Output Layout | Validation Pre-processing Post-processing
acets
File > Project B H+ -2
Structure... > Project Platform Settings <output root>
. . SDKs META-INF
Settings > Artifacts > N \ i ,
Global Libraries we MANIFE i Create Directory [/workspace-nuclos4/nuclos/nuclos
Qut put Layout > META-INF WEB-INF Create Archive
Problems 1 LAGIEEERE  Add Copy of L Il Library Files
hinzuzuﬁ_]gen. — Remove ® = Module Output
Extract Artifact... ©1 Module Test Output
Inline Artifact = File
Rename {F6 Directory Content
Surround With... 88T B Extracted Directory
W, JavaEE Facet Resources
Navigate ®
Find Usages XF7
= Expand All B+
= Collapse All %-

Wenn das Projekt auf einer Oracle-
Datenbank basiert, ist ein weiterer
Schritt notwendig:

Die ojdbc6.jar (ggf. in der
passenden Oracle-Version) muss
das Verzeichnis /[Pfad zu Kern-git]
Inuclos-war/src/main/webapp/META-
INF/lib kopiert werden (bei
Extensions wieder entsprechend <ex
tension-war>).

Der Server kann jetzt gestartet
werden. (Am besten im Debug-
Modus)

Wenn es beim Server-Start eines
Extensions-Projekts Kompilierfehler
bei den Regeln gibt, weil einige
Nuclos-Klassen nicht gefunden
werden konnen, stellen Sie sicher,
dass die Bibliothek nuclos-ccce.jar u
nter dem Pfad /[Pfad zu Projekt-git]
/<extension>-war/target/<extension>-
war/webapp/WEB-INF/lib zu finden
ist.

Wenn die Datei dort fehlt, fligen Sie
die nuclos-ccce - Dependency aus
der /nuclos-war/pom.xml in die
/<extension>-war/pom.xml ein.
Danach das Projekt neu bauen (s.u.).

AbschiieBend muss noch der Client

erstellt werden: + — Mm% Name: | TomtestisD

Add New Configuration
[ Android JUnit

i Ant Target Application server: | Tomcat 7.0.72

SEWEF| Deployment | Logs | Code Cove

& Applet
Open browser
S -
& Chromiurn Remote |http:,f,flocalhost:SUSU,fnucLos-war/
" Compound

@ Cucumber java VM options: -Dfunctionblor
I @ Firefox Remote R /7

2 Gradle lpdeie ctim: | Hesiart Samar|

7 Griffon On frame deactivation: Do nothing

& Groovy

& Gruntjs JRE: | Default (1.8 - project SDK)

¥ Gulp.js

: c Tomcat Server Settings
- JAR Application

& JavaScript Debug HTTP port: | 8080

n

St L
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K Kotlin JMXport: 1099
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Konfiguration des Clients:

+ —h % Name: ‘\SD Client ‘ [ Share [ Single jnstance only
Main class org.nuclos. =1 Application Configuration | Code Coverage | Logs |
client.main =1SD Client
NUC|0’S ' ¥ Tomcat Server Main class: ‘ org.nuclos.client.main.Nuclos |D
[T
# pefaules VM options: ‘ s-warfremoting -Dfunctionblock dev=true -Dsun.awt.disablegrab=true ”E‘
VM Options -ea Program arquments: |@
(Port muss ggf -Xmx768m Working directory: ‘/hcme/max/git/nudet—isd |D@
angepaSSt -DSerVef:http:/ Environment variables: ‘ |D
werden) /localhost:8080
/nuclos-war Use classpath of module: ‘ & nuclos-client n
- . JRE: | Default (1.8 - SDK of 'nuclos-client’ module) D
Dfunctionblock g
.dev=true [ Enable capturing Form snapshots
-Dsun.awt.
disablegrab=tr
ue ~ Before launch: Build, Activate tool window
+
Use classpath nuclos-client 1 Build
of module
Danach kann der Client gestartet [ Show this page [ Activate tool window
werden. (Am besten im Debug-
Modus)

| Cancs\.l ‘ App | ‘ Help ‘

Das Projekt neu bauen

Eine erfolgreiche Einbindung von Nuclos in Intellij ist nicht immer einfach und ein Scheitern kann verschiedene Ursachen haben. Hier ist
moglicherweise etwas Geduld gefragt. Manchmal reicht es auch, das Projekt noch einmal von Null an bauen zu lassen.

Wenn Sie an der Konfiguration oben etwas geéndert haben und/oder nochmal alles sauber aufbauen wollen, gehen Sie bitte wie folgt vor:

Intellij aufrAumen und neu starten Unter File > Invalidate Caches... alle Checkboxen anhaken und Invalidate and
Restart
Reload all Maven Projects
Mawven g — =
S ke i+ m » 2
o
> | Profiles =
Reload All Maven Projects
i Imt-client m
=
i Imt-common o
g
I iy Imt-server
Clean auf allen root - Maven-Projects i Nuclos (root)
o Lifecycle
| validate
compile

test


http://localhost:8080/nuclos-war/jmsbroker
http://localhost:8080/nuclos-war/jmsbroker
http://localhost:8080/nuclos-war/jmsbroker

Generate Sources and Update Folders auf allen root - Maven-

Projects Maven g — =
' G ™ * E
0 —
1 w60 vIG e x| + m » =
(=g
. oo
o Profiles =
> = It (rantl 1

= Reload project

Generate Sources and Update Folders

Rebuild Project : i
iGN Fun Tools Git

“\ Build Project
Build Module 'nuclos’
Rebuild

Recompile

Window Help n
Strg+F9

Strg+ Umschalt+F9

Strg+Umschalt+F9

Rebuild Project

Build Artifacts...
Groovy Resources L
Run Ant Target strg+Umschalt+F10 |

Troubleshooting

IntelliJ erkennt /[Pfad zu Projekt-Installation]/tomcat/apache-tomcat-9.x nicht als Tomcat-Home an.

Das Projekt wird gebaut, aber der Server startet nicht mit der Meldung:

"SEVERE: Unable to process Jar entry [nodul e-info.class] fromJar [jar:
file:/sahibinden/repo/ servi ces/ sahi bi nden-web/ t ar get/ sahi bi nden- web/ V\EB-
INF/1ib/classgraph-4.6.7.jar!/] for annotations org.apache.tontat.util.
bcel . cl assfil e. O assFormat Exception: Invalid byte tag in constant pool:
19"

Localhost:8080 is already in use.

Weitere Gruinde fiir das Scheitern des Server-Starts

Mdogliche Probleme und Behebung

Serverstart: nuclos-conf.xml nicht gefunden

Projekt - open Module Settings

Die entsprechende Tomcat-Version muss
manuell installiert werden. Hier eine
Beispielanleitung: https://medium.com
/@dolthead/upgrade-intellij-idea-to-tomcat-9-
0-8-d2a560606231

Es handelt sich um einen Bug mit der
Kombination aus Tomcat - und Java -
Version (https://github.com/classgraph
[classgraph/issues/291).

Die neueste JDK 8 benétigt z.B. Tomcat 9.

Es lauft bereits ein Programm auf dem Port
8080. Dieses passiert z.B. in Ubuntu, wenn
man Tomcat aus den Paketquellen installiert
und nicht manuell abschaltet.

Das in der Projekt-Installation angegebene
Schema muss in der Datenbank existieren
(es kann aber leer sein).


https://medium.com/@dolthead/upgrade-intellij-idea-to-tomcat-9-0-8-d2a560606231
https://medium.com/@dolthead/upgrade-intellij-idea-to-tomcat-9-0-8-d2a560606231
https://medium.com/@dolthead/upgrade-intellij-idea-to-tomcat-9-0-8-d2a560606231
https://github.com/classgraph/classgraph/issues/291
https://github.com/classgraph/classgraph/issues/291
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