Zum Ende der Metadaten springen
Zum Anfang der Metadaten

Eclipse Plugin zur Unterstützung der Regelentwicklung

Mit unserem Eclipse Plugin "Nuclos IDE" können Regeln einfacher entwickelt werden. Es bietet die gewohnte Code-Completion einer Eclipse Umgebung und ermöglicht zusätzlich das Debuggen der Regeln zur Laufzeit.

Voraussetzungen

Eclipse

  • Die neuste Version der Springsource Eclipse Distribution STS (z.Z. 3.5.0) basierend auf Eclipse 4 wird empfohlen.
  • Auch unterstützt werden die Eclipse IDE for Java EE Developer Juno SR2 (4.2.x) und Kepler SR1 (und SR2-RCx) (4.3.x)
    (Es werden immer nur die aktuellen service releases (SR) der entsprechenden Eclipse Version unterstützt.)
  • Eclipse muss unter Java7 (oder Java8) laufen
  • Nicht unterstützt werden Eclipse vor e4 (d.h. 3.x)

 

Sollten Sie feststellen, dass das Eclipse Plugin trotz dieser Voraussetzungen bei Ihnen nicht funktioniert, eröffnen Sie bitte ein Ticket unter Nuclets ERP. Sie können die offenen Tickets unter ERP open/unresolved einsehen.

Nuclos

  • Nuclos Version 3.13 oder höher,
    als Entwicklungsumgebung installiert
    (neu ab dieser Version):
  • Eclipse Plugin und Nuclos in zueinander passenden Versionen, siehe auch:

 

Bitte beachten Sie, dass das Eclipse Plugin nur für API-basierte Serverregeln (und zukünftig auch API-basierte Clientregeln) funktionert (Menüpunkt Konfiguration/Regeln/Serverregeln (API-basiert) funktioniert. Alte Regeln vor Nuclos 4.0 (Menüpunkte Konfiguration/Regeln/Bibliotheksregeln, Konfiguration/Regeln/Fristenregeln und Konfiguration/Regeln/Geschäftsregeln) werden durch das Eclipse Plugin nicht unterstützt.

Bitte beachten Sie, dass für alte Versionen des Eclipse Plugins (für Nuclos 3.13) in Eclipse das Encoding ggf. auf UTF-8 umgestellt werden muss. Neuere Versionen ändern diese Einstellung automatisch.

Installation

Das Plugin zur Installation finden Sie in unserem Nuclet Download Bereich
bzw. unter https://bitbucket.org/nuclos/nuclos-ide.git
 
Öffnen Sie in Eclipse den Installationsmanager (Help -> Install New Software...) 

Fügen Sie das Plugin mittels des Buttons "Add..." zur Auswahl hinzu.
Wählen Sie hierzu "Archive..." und geben Sie einen Namen ein.

Nun können Sie das Plugin wählen und die Installation starten.
Eclipse muss nach der Installation neu gestartet werden. 

Alternative Installation

Dieses alternative Installationsverfahren ist für die Nuclos interne Entwicklung gedacht. Es funkioniert nicht für Externe.

Zunächst mount(s) einrichten, wie unter Interne Konfiguration beschrieben.

2. Einrichten der Software Site

Name:  Mounted Nuclos Jenkins Builds

Location: file:/home/tpasch2/mnt/Public/builds/nuclos-ide-master/repository/

Bedienung

Classpath erweitern (ab Nuclos 4.8.1)

Verwenden die Regeln in Ihrem Nuclet Klassen von Drittbibliotheken?

Dann geben Sie im Nuclet Parameter NUCLOS_SERVERCODE_CLASSPATH_EXTENSION die Erweiterung des Classpath an.
Das Plugin wird dann automatisch die zusätzlichen Bibliotheken vom Server laden.

 

Neues Projekt anlegen

Hierzu müssen Sie den Wizard für neue Projekte von Eclipse öffnen.

Zum Beispiel über das Menü File -> New -> Project...
Oder dem Kontext im Package Explorer Baum. 

Im Bereich "Nuclos" finden Sie das "Server Project".

Fahren Sie mit dem Wizard fort.

Im nächsten Schritt müssen Sie die Daten des Nuclos Servers angeben,
welche auch schon bei der Installation abgefragt wurden.

Ist Nuclos auf Ihrem Rechner installiert, und wenn Sie bei der Installation
keine anderen Einstellungen gewählt haben, so dürften die Einstellungen
schon für Sie korrekt sein. 

Sie müssen eine aktuelle Nuclos Version 3.13 verwenden,
und bei der Installation den neuen Punkt
Entwicklungsumgebung gewählt haben.
Nur dann wird ein Debug Port geöffnet!

Im Anschluss müssen Sie die Verbindung testen. Nur wenn der Test
erfolgreich war können Sie den Wizard abschließen. 

Im letzten Schritt müssen Sie dem Projekt noch einen Namen geben.

Im Anschluss finden Sie ein neu eingerichtetes Projekt in Ihrem
Workspace vor. 

 

Regeln bearbeiten und hochladen

Die Regeln finden Sie unter "serverrule".
Die Bearbeitung einer Regel unterscheidet sich nicht von anderen
Java Klassen in anderen Projekten.

Die anderen Bereiche enthalten die von Nuclos generierten Klassen für

  • Business Objects
  • Statusmodelle
  • Generatoren
  • Reports

Diese können jedoch nicht geändert werden!

Die Funktion zum hochladen der Änderungen ist im Kontext Menü des
Projektes zu finden.
Nur Package Explorer, nicht im Projekt Explorer!

Ebenso die Funktion zum Download, falls mal Änderungen direkt im
Client vorgenommen wurden, oder ein Nuclet importiert wurde etc. 

 

Regeln debuggen

Auch das Debuggen einer Regel unterscheidet sich nicht von anderen
Java Klassen bzw. Anwendungen. Setze Sie einfach die Haltepunkte
an die gewünschten Stellen. Im Anschluss verbinden Sie sich mit der
vom Plugin eingerichteten Remote Application Konfiguration zum
Nuclos Server. Die Konfiguration wurde so wie das neue Projekt
genannt.

Wenn nun die Regel von Nuclos angesprochen wird, wird der
Haltepunkt angesprungen. 

Wenn Sie die Verbindung zum Server wieder trennen möchten, so
finden Sie die Funktion in der Debug Ansicht
(Window -> Open Perspective -> Debug) 

 

Einstellungen ändern

Die bei der Einrichtung eingetragen Werte können über die Einstellungen
des Projektes jederzeit wieder geändert werden. 
  • Keine Stichwörter